Excel'de Mantıksal İşlevler Nasıl Kullanılır: IF, AND, OR, XOR, NOT

 

Mantıksal işlevler, Excel'deki en popüler ve kullanışlı işlevlerden bazılarıdır. Diğer hücrelerdeki değerleri test edebilir ve testin sonucuna bağlı olarak eylemler gerçekleştirebilirler. Bu, elektronik tablolarımızdaki görevleri otomatikleştirmemize yardımcı olur.


Excel'de Mantıksal İşlevler Nasıl Kullanılır: IF, AND, OR, XOR, NOT



EĞER İşlevi Nasıl Kullanılır


EĞER işlevi Excel'deki ana mantıksal işlevdir ve bu nedenle ilk anlaşılması gereken işlevdir. Bu makale boyunca birçok kez görünecek.


EĞER işlevinin yapısına bir göz atalım ve sonra kullanımına ilişkin bazı örnekler görelim.


EĞER işlevi 3 bitlik bilgiyi kabul eder:


  • =EĞER(mantıksal_test, [doğruysa_değer], [yanlışsa_değer])
  • mantıksal_test: Bu, işlevin kontrol etmesi için koşuldur.
  • value_if_true: Koşul karşılanıyorsa veya doğruysa gerçekleştirilecek eylem.
  • eğer_yanlışsa_değer: Koşul karşılanmıyorsa veya yanlışsa gerçekleştirilecek eylem.
  • Mantıksal Fonksiyonlarla Kullanılacak Operatörleri Karşılaştırma
  • Hücre değerleriyle mantıksal testi gerçekleştirirken karşılaştırma operatörlerine aşina olmanız gerekir. Bunların dökümünü aşağıdaki tabloda görebilirsiniz.


Mantıksal fonksiyonlar için karşılaştırma operatörleri


Şimdi eylemdeki bazı örneklere bakalım.


IF İşlevi Örnek 1: Metin Değerleri


Bu örnekte, bir hücrenin belirli bir ifadeye eşit olup olmadığını test etmek istiyoruz. EĞER işlevi büyük/küçük harfe duyarlı değildir, bu nedenle büyük ve küçük harfleri dikkate almaz.


Aşağıdaki formül, B sütununda "Tamamlandı" metnini içeriyorsa "Hayır" ve başka bir şey içeriyorsa "Evet" ifadesini göstermek için C sütununda kullanılır.


=EĞER(B2="Tamamlandı", "Hayır", "Evet")

Metin değerlerini test etmek için EĞER işlevi


EĞER işlevi büyük/küçük harfe duyarlı olmasa da metin tam olarak eşleşmelidir.


IF İşlevi Örnek 2: Sayısal Değerler

EĞER işlevi, sayısal değerleri karşılaştırmak için de harikadır.


Aşağıdaki formülde, B2 hücresinin 75'e eşit veya daha büyük bir sayı içerip içermediğini test ediyoruz. Varsa, "Geçti" kelimesini, değilse "Başarısız" kelimesini görüntüleriz.


=EĞER(B2>=75,"Başarılı", "Başarısız")

Sayısal değerlerle koşul varsa


EĞER işlevi, bir testin sonucunda farklı metinler görüntülemekten çok daha fazlasıdır. Farklı hesaplamalar yapmak için de kullanabiliriz.


Bu örnekte, müşteri belirli bir miktar para harcarsa %10 indirim vermek istiyoruz. Örnek olarak £ 3,000 kullanacağız.


=EĞER(B2>=3000,B2*90%,B2)

EĞER işlevini kullanarak koşullu formül


Formülün B2*%90 kısmı, B2 hücresindeki değerden %10'u çıkarmanın bir yoludur. Bunu yapmanın birçok yolu var.


value_if_trueÖnemli olan veya value_if_falsebölümlerinde herhangi bir formülü kullanabilmenizdir . Ve diğer hücrelerin değerlerine bağlı olarak farklı formüller çalıştırmak, sahip olunması gereken çok güçlü bir beceridir.


IF İşlev Örneği 3: Tarih Değerleri

Bu üçüncü örnekte, son tarihlerin listesini izlemek için EĞER işlevini kullanıyoruz. B sütunundaki tarih geçmişte ise “Gecikmiş” kelimesini görüntülemek istiyoruz. Ancak tarih gelecekteyse, vade tarihine kadar geçen gün sayısını hesaplayın.


Aşağıdaki formül C sütununda kullanılır. B2 hücresindeki son tarihin bugünün tarihinden küçük olup olmadığını kontrol ederiz (BUGÜN işlevi bilgisayarın saatinden bugünün tarihini döndürür).


=EĞER(B2<BUGÜN(),"Gecikmiş",B2-BUGÜN())

Tarihlerin gelip gelmediğini test etme


İç İçe EĞER Formülleri nedir?


Daha önce iç içe IF'ler terimini duymuş olabilirsiniz. Bu, başka bir EĞER işlevinin içine bir EĞER işlevi yazabileceğimiz anlamına gelir. Yapacak ikiden fazla eylemimiz varsa bunu yapmak isteyebiliriz.


Bir EĞER işlevi iki eylemi ( value_if_trueve value_if_false) gerçekleştirebilir. value_if_falseAncak bölüme başka bir EĞER işlevi yerleştirirsek (veya yerleştirirsek) , başka bir işlem gerçekleştirebiliriz.


Bu örneği, B2 hücresindeki değer 90'dan büyük veya 90'a eşitse “Mükemmel” kelimesini, değer 75'e eşit veya daha büyükse “İyi” ve başka bir şey varsa “Kötü” kelimesini görüntülemek istediğimiz yere alın. .


=EĞER(B2>=90,"Mükemmel",EĞER(B2>=75,"İyi","Kötü"))


Şimdi formülümüzü, yalnızca bir EĞER işlevinin yapabileceğinin ötesine genişlettik. Ve gerekirse daha fazla EĞER işlevini iç içe yerleştirebilirsiniz.


Her bir EĞER işlevi için bir tane olmak üzere, formülün sonundaki iki kapatma parantezine dikkat edin.


Bu iç içe EĞER yaklaşımından daha temiz olabilecek alternatif formüller vardır. Çok kullanışlı bir alternatif, Excel'deki SWITCH işlevidir .


AND ve OR Mantıksal İşlevleri

VE ve VEYA işlevleri, formülünüzde birden fazla karşılaştırma yapmak istediğinizde kullanılır. EĞER işlevi tek başına yalnızca bir koşulu veya karşılaştırmayı işleyebilir.


Bir müşterinin harcadığı miktara ve kaç yıldır müşteri olduğuna bağlı olarak bir değeri %10 oranında indirdiğimiz bir örnek alın .


VE ve VEYA işlevleri kendi başlarına DOĞRU veya YANLIŞ değerini döndürür.


AND işlevi, yalnızca her koşul karşılandığında DOĞRU, aksi takdirde YANLIŞ döndürür. VEYA işlevi, koşullardan biri veya tümü karşılanırsa DOĞRU döndürür ve yalnızca hiçbir koşul karşılanmazsa YANLIŞ döndürür.


Bu işlevler 255'e kadar koşulu test edebilir, bu nedenle kesinlikle burada gösterildiği gibi sadece iki koşulla sınırlı değildir.


AND ve OR fonksiyonlarının yapısı aşağıdadır. Aynı yazılırlar. VEYA yerine VE adını koymanız yeterlidir. Farklı olan sadece onların mantığıdır.


=VE(mantıksal1, [mantıksal2] ...)

Her ikisinin de iki koşulu değerlendirdiği bir örnek görelim.


VE İşlev örneği

VE işlevi, müşterinin en az 3.000 £ harcayıp harcamadığını ve en az üç yıldır müşteri olup olmadığını test etmek için aşağıda kullanılır.


=VE(B2>=3000,C2>=3)

VE işlevi Excel'de


Matt ve Terry için YANLIŞ döndürdüğünü görebilirsiniz, çünkü her ikisi de ölçütlerden birini karşılasalar da VE işleviyle her ikisini de karşılamaları gerekir.


VEYA İşlev Örneği

VEYA işlevi, müşterinin en az 3.000 £ harcadığını veya en az üç yıldır müşteri olup olmadığını test etmek için aşağıda kullanılır.


=VEYA(B2>=3000,C2>=3)

VEYA mantıksal işlevi


Bu örnekte, formül Matt ve Terry için DOĞRU değerini döndürür. Yalnızca Julie ve Gillian her iki koşulda da başarısız olur ve YANLIŞ değerini döndürür.


VE ve VEYA EĞER İşleviyle Kullanma

AND ve OR işlevleri, tek başlarına kullanıldıklarında DOĞRU veya YANLIŞ değerini döndürdükleri için, bunları kendi başlarına kullanmak nadirdir.


Bunun yerine, formül DOĞRU olarak değerlendirilirse bazı geriye dönük eylemler gerçekleştirmek için bunları genellikle EĞER işleviyle veya Koşullu Biçimlendirme veya Veri Doğrulama gibi bir Excel özelliği içinde kullanırsınız.


Aşağıdaki formülde, AND işlevi, EĞER işlevinin mantıksal testinin içine yerleştirilmiştir. VE işlevi DOĞRU döndürürse, B sütunundaki tutardan %10 indirim yapılır; aksi halde indirim yapılmaz ve B sütunundaki değer D sütununda tekrarlanır.


=EĞER(VE(B2>=3000,C2>=3),B2*%90,B2)

EĞER ve VE işlevleriyle Excel formülü


XOR İşlevi

VEYA işlevine ek olarak, özel bir VEYA işlevi de vardır. Buna XOR işlevi denir. XOR işlevi, Excel 2013 sürümüyle tanıtıldı.


Bu işlevi anlamak biraz çaba gerektirebilir, bu nedenle pratik bir örnek gösterilmiştir.


XOR işlevinin yapısı VEYA işleviyle aynıdır.


=XOR(mantıksal1, [mantıksal2] ...)

Yalnızca iki koşulu değerlendirirken XOR işlevi şunu döndürür:


Her iki koşul da TRUE olarak değerlendirilirse TRUE.

Her iki koşul da DOĞRU ise veya hiçbir koşul DOĞRU değilse YANLIŞ.

Bu, VEYA işlevinden farklıdır, çünkü her iki koşul da DOĞRU olsaydı, bu DOĞRU döndürür.


Bu işlev, daha fazla koşul eklendiğinde biraz daha kafa karıştırıcı hale gelir. Ardından XOR işlevi şunu döndürür:


Tek sayıda koşul TRUE döndürürse TRUE .

YANLIŞ, çift sayıda koşul DOĞRU ile sonuçlanırsa veya tüm koşullar YANLIŞ ise.

XOR fonksiyonunun basit bir örneğine bakalım.


Bu örnekte, satışlar yılın iki yarısına bölünmüştür. Bir satış elemanı her iki yarıda da 3.000 £ veya daha fazla satarsa, bu kişiye Altın standardı atanır. Bu, makalenin önceki bölümlerinde olduğu gibi EĞER içeren bir VE işleviyle elde edilir.


Ancak her iki yarıda da 3.000 £ veya daha fazla satarlarsa, onlara Gümüş statüsü vermek istiyoruz. Her ikisinde de 3.000 £ veya daha fazla satmazlarsa hiçbir şey olmaz.


XOR işlevi bu mantık için mükemmeldir. Aşağıdaki formül E sütununa girilir ve yalnızca herhangi bir koşul karşılandığında "Evet" veya "Hayır" görüntülemek için EĞER ile XOR işlevini gösterir.


=EĞER(XOR(B2>=3000,C2>=3000),"Evet","Hayır")

Excel'deki XOR İşlevi


DEĞİL İşlevi

Bu makalede tartışılacak son mantıksal işlev DEĞİL işlevidir ve en basitini sona bıraktık. Her ne kadar bazen işlevin 'gerçek dünya' kullanımlarını ilk başta görmek zor olabilir.


DEĞİL işlevi, bağımsız değişkeninin değerini tersine çevirir. Bu nedenle, mantıksal değer DOĞRU ise, YANLIŞ döndürür. Mantıksal değer YANLIŞ ise DOĞRU değerini döndürür.


Bunu bazı örneklerle açıklamak daha kolay olacaktır.


DEĞİL fonksiyonunun yapısı;


=DEĞİL(mantıksal)

DEĞİL İşlev Örneği 1

Bu örnekte, Londra'da bir merkez ofisimiz ve ardından diğer birçok bölgesel sitemiz olduğunu hayal edin. Site Londra dışında bir şeyse “Evet”, Londra ise “Hayır” kelimesini görüntülemek istiyoruz.


DEĞİL işlevi, DOĞRU sonucu tersine çevirmek için aşağıdaki EĞER işlevinin mantıksal testinde yuvalanmıştır.


=EĞER(DEĞİL(B2="Londra"),"Evet","Hayır")



Bu, <> mantıksal DEĞİL operatörü kullanılarak da gerçekleştirilebilir. Aşağıda bir örnek bulunmaktadır.


=EĞER(B2<>"Londra","Evet","Hayır")

DEĞİL İşlev Örneği 2

DEĞİL işlevi, Excel'deki bilgi işlevleriyle çalışırken kullanışlıdır. Bunlar, Excel'de bir şeyi kontrol eden ve kontrol başarılıysa DOĞRU, değilse YANLIŞ döndüren bir işlev grubudur.


Örneğin, ISTEXT işlevi, bir hücrenin metin içerip içermediğini kontrol edecek ve içeriyorsa DOĞRU, içermiyorsa YANLIŞ değerini döndürecektir. DEĞİL işlevi yararlıdır çünkü bu işlevlerin sonucunu tersine çevirebilir.


Aşağıdaki örnekte, bir satış elemanına sattığı miktarın %5'ini ödemek istiyoruz. Ancak herhangi bir şey satmadıysalar, hücrede “Hiçbiri” kelimesi bulunur ve bu, formülde bir hataya neden olur.


ISTEXT işlevi, metnin varlığını kontrol etmek için kullanılır. Metin varsa bu TRUE değerini döndürür, bu nedenle NOT işlevi bunu FALSE olarak tersine çevirir. Ve IF hesaplamasını yapar.


=EĞER(DEĞİL(ISTEXT(B2)),B2*5%,0)

DEĞİL işlevi örneği 2


Mantıksal işlevlerde uzmanlaşmak, bir Excel kullanıcısı olarak size büyük bir avantaj sağlayacaktır. Hücrelerdeki değerleri test edip karşılaştırabilmek ve bu sonuçlara göre farklı işlemler yapabilmek çok faydalıdır.


Bu makale, günümüzde kullanılan en iyi mantıksal işlevleri ele almıştır. Excel'in son sürümlerinde, bu makalede bahsedilen XOR işlevi gibi bu kitaplığa eklenen daha fazla işlevin tanıtıldığı görülmüştür. Bu yeni eklemelerle güncel kalmak, sizi kalabalığın önünde tutacaktır.


Yorum Gönder

Daha yeni Daha eski